Compatible devices

The Vision+ 2 app requires a 5G WiFi capable Apple or Android device. This is to ensure that the WiFi connection is powerful enough to prevent latency, freezing, or crashing issues while registering and flying the drone.

If you wish to use your device to operate the PowerDolphin, it must be capable of supporting:

Wi-Fi – 802.11a/b/g/n Wi-Fi (802.11n 2.4GHz and 5GHz) / Bluetooth 4.0 wireless technology.

This is a partial list of devices recommended by PowerVision pilots. We have found that the user experience with Apple iOS is superior — however, we are working to achieve the same user experience with Android.

Apple Devices (Requires iOS 9.0 or later)

  • iPhone 5s
  • iPhone 6
  • iPhone 6 Plus
  • iPhone 6s
  • iPhone 6s Plus
  • iPhone SE
  • iPhone 7
  • iPhone 7 Plus
  • iPhone 8
  • iPhone 8 Plus
  • iPhone X
  • iPhone XS
  • iPhone XS Max
  • iPhone XR

Android Devices (Android version 5.0 or later)

  • Samsung Note5
  • Samsung Note6
  • Samsung Galaxy S5
  • Samsung Galaxy S6
  • Samsung Galaxy S6 Edge
  • Samsung Galaxy S7 Edge
  • Samsung S8
  • Huawei P10
  • Huawei P9
  • Huawei P8
  • Huawei Honor 8
  • Huawei Mate9
  • Huawei Mate8
  • Xiaomi Mi5
  • Xiaomi Mi5s
  • OPPO R11S
  • Moto Z
  • OnePlus 5T

Note: There are a lot of different Android devices in the market. And we cannot test out ALL the devices. If you want to use a device that is not on the list, please contact us first.

Note: Currently Vision+ 2 does not support tablet devices.

Modified on: 2020-04-09 14:19

PowerVision Contact Info

After Sales & Technical Support

sea@powervision.me

Phoneline Operating Hours: Monday - Friday - 9:00 - 17:00

Supported Language: English